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CS Soft Network Client

Dear customer,

Every year thousands of customers purchase our high quality products.
With very good reason:

e Our products offer a very good price/performance ratio. Reliable quality at a fair price.

e With a professional experience of over 20 years, we are able to find the optimal solution for

your measuring task.
e Our high quality standards.
e Of course, all of our equipment bears the CE mark required by the EU.
e Calibration certificates, seminars and consulting.
e After the purchase we will not leave you standing in the rain.

Our service ensures rapid assistance for you.
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1 Introduction

With the help of OMClient, the stored measurement values can be visualized and evaluated.

2 First Start

e The first time the application is started a notice will be displayed, stating that a connection to

the database cannot be established.

Fehler

[

v 1 Unable to connect to Database. Please check your Database connection

settings or contact the database administrator,

Details:
Access denied for user ‘root'@ localhost’ (using password: YES)

Wiederholen Abbrechen

e By pressing the "Retry" button the "database configuration” dialogue is automatically opened.

e The dialogue “database configuration® is filled with the standard parameters for the MySQL

lllustration 1: No database connection

Name/IP address of the computer
where the MySQL database is installed.

database.
¢ Now you can change the parameters for the MySQL database:
& Configure Database @
MySQL Database Connection Settings /
Hostname: localhost
Port: 3306 =

Password:

Database Mame: cs_omdatabase

Usemame: root

[ \@K \]| Cancel |
A\

lllustration 2: Databasg configuration

Port of the MySQL database (default:
3306 - see Install Guide p. 11)

Name of the database (default:
cs_omdatabase - see Install Guide p.
13)

Database User: root

Password for the database access (see
the Install Guide, p. 13 (default:
CS_DB)
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3

The dialog for the configuration of the MySQL database connection can be called up at any
time via the menu item "Extras -> Database configuration".

After correctly entering the database configuration the logon dialog will appear. Enter the
correct login credentials. The credentials were established with the help of OMServerGUI (see
Manual CS Soft Online Monitoring ServerGUI p. 14)

Subsequently a message will appear stating that a connection to the OMServer can not be
established:
Warnung =

Cennection to Server lost.

B\ The service you have requested is not available at this ime. Its possible
it may have disappeared by accident and will be back someday, but it's
also possible the service admin removed it on purpose and with malice
aforethought, and that it will never be seen again. Or maybe it never
existed.

You will not be able to receive values of the connected devices,

Illustration 3: Connection to Server Lost

Acknowledge the warning by clicking "OK".

After this the dialogue ,“Client Server Communication® appears.
The dialogue is filled with the standard parameters fort he Client — Server — Communication.

Now you can change the parameters for the Client — Server — Communication:
& Client Server Communication @

Server Endpoint Corfiguration
Hostname: Jocalhost]

Port: 47825

. Name/IP address of the computer
where the OMServer is installed.

¥

ok ][ Ccancs e  Port of the OMServer (default: 47825 -
see Manual CS Soft Online Monitoring
ServerGUI p. 13)

Illustration 4: Client Server Communication

Subsequently restart OMClient.

General

Here, the menu items are described that have the same functionality in all views.

3.1 Menu File

3.1.1 Exit
Exit the OMClient.

3.2 Menu View

This menu can be used to switch through the different views.
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3.3 Menu Extras

3.3.1 Alarm texts

With this menu item the mask to define the alarm texts is displayed.

The alarm texts can also be defined with the OMServerGUI.

To be able to define alarm texts the user must at least have a level 3 access authorization.
The Alarmld (alarmTextID) is assigned by the software.

The alarm texts can also be defined in different languages.

A further language can be added with the button "add language".

& Alarm Text Configuration o 5] s
[ | Add alarm text in the selected language
alam Tesd 1D en de |3'|/ (hlgh“ghted COlumn)'
» I 1.- Fehler |—:4\
2 Yolie doesrt mch Thd| | Weet unsinia or @\¥ e  Edit alarm text in the selected language
3 Alam: Flow too big! Alarm: Durchfluss zu...

(highlighted column).

. Delete selected alarm texts in all
languages.

|- Edit alarm text.

Aam TextCorffiguration
Alam text

e  Add additional language.

e  Accept change.

e Reset change.

\ [ Unigek | | Cose |

lllystratioyn 5: Configuring alarm texts

e  Authorization - changes can be made by others.

e  Alarm text editing - the current mask is locked for other users.
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3.3.2 E-mail recipient configuration

he e-mail recipients can be defined in the following

Mail Recipients
name eMailAddress
aabt

Tanja Ebner

Mail Recipient Corfiguration

MName: |Tanja Ebner |

Mail Address: |ehnertanja@ehner—engineenng de |

e

o=

lllustration 6: E-mail recipient

e The "Edit" button must be clicked to enable editing. It is checked whether the current mask is
already being edited by another user. If so, ho changes can be made. If not, the current mask
will be authorized for the current user and locked for all other users.

e Alanguage can be assigned to each user. The alerts will be sent in the specified language.

3.3.3 SMS recipient configuration

SMS recipient corfiguration

MName: |aabt |

Mobile phone number: | 004317656755628 |
e.g: 0045301234567 {without space and +or -}

e

[Bditon] [ Unlock |

lllustration 7: SMS recipient
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e The "Edit" button must be clicked to enable editing. It is checked whether the current mask is
already being edited by another user. If so, no changes can be made. If not, the current mask
will be authorized for the current user and locked for all other users.

¢ Alanguage can be assigned to each user. The alerts will be sent in the specified language.

3.3.4 Database configuration

¢ In this dialog, the correct parameters for the MySQL database must be entered:

& Configure Database @
MySQL Database Conneciion Settings / . Name/IP address of the computer
Hostname Iocakhast where the MySQL database is installed.
Port: 3306 =
Database Name: cs_omdatabase
;
Usemame oot
Pasenond — . Port of the MySQL database (default:
) 3306 - see Install Guide p. 11)
conky

. Name of the database (default:
cs_omdatabase - see Install Guide p.
13)

lllustration 8: Databasg coyfiguration

. Database User: root

. Password for the database access (see
the Install Guide, p. 13 (default:
CS DR)

3.3.5 Client - Server communication configuration

¢ In this dialogue, the correct parameters for the OMServer must be entered:
& Client Server Communication @

Server Endpoint Configuration . Name/IP address of the computer

where the OMServer is installed.

Hostname:

. Port of the OMServer (default: 47825 -
see Manual CS Soft Online Monitoring
ServerGUI p. 13)

3.4 Menu Info

3.4.1 Help
e Calls up the Help file (PDF File).

3.4.2 Language

e A dialog for the language selection will be opened:

@~ Select Language @
Available Languages
‘ English - ‘
o]

lllustration 9: Language selection

e The combo box will display all the languages available.

o Restart the application, if there are problems with the display after switching the language.
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3.4.3 About

e The current version information will be displayed.

4 Qverview

e After the start the "Overview" screen will always be displayed.

e If you are in another view, you can always switch back to the overview through the menu item
"View -> Overview".

e This screen can be freely configured by the user.

e Background image:

When using a background image, the devices can be positioned on the entire background
image - otherwise on the entire screen.

Menu item Toolbar Action
Edit -> Wallpaper -> Add Il Adding a background image
Edit -> Wallpaper -> Delete £} Deleting a background image

Table 1: Background image

¢ Inthe draft mode, devices can be added to the surface and positioned freely. The current
measured values are displayed in the device window. An upcoming alarm or incorrect values
are highlighted in red.

Menu item Toolbar Action
Edit -> Draft li, Draft mode on/off
Edit -> Add device iy Dialog for adding a device is
opened. Double-click on the
desired device to add it.

Table 2: Editing Overview
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@ CSInstruments GmbH - ONLINE Monitoring Client
File Edit View Extras Info
DEH k@@
‘T'—_-'%W""f“ T Draft mode active
The frame is
displayed in the
draft mode.

¢ 230192.168.0.230:502 ModbusID: 1 o| =3 | %)
230 192.168.0.230:502 ModbusID: 1 —|
description value unit Deleting a device
temp 25.7 <
29.4 YorH
T g
0.0 °Ctd

Alarm is pending.

»

< 1m

4488 - Value doesn't ma’t(h “Ctd! :

z# Connected

Illustration 10: Draft mode overview

e The current overview will be saved automatically when you exit and loaded the next time the
software is started.

¢ As many overviews as desired can be saved.

Menu item Toolbar Action

File -> New B Creating a new overview. If
the current view was not
saved in a file, the data will be
lost.

File -> Open = The dialog "Open file" with a
filter for overview files ("*.
cssh™) will be opened.

File -> Save = The currently selected file is
saved. If no file is currently in
use, the dialog "Save as ..."
will automatically open.

File -> Save as (= The dialog "Save as ..." will
open. When overview file are
saved the file extension "*,
cssh" is used.
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Table 3: Overviews

e Using the context menu, the following actions can be performed:

o Graphical display of all measured values of the selected device within the selected
time range.

o Alarm configuration for the selected measured value (see 8 Alarm Configuration).

5 Data

e The menu item "View -> Data" switches to the data view.
e A switching to the data view is also possible through the device context menu.

¢ Inthe Diagram Explorer, all areas are listed to which the current user has access. The devices
are structured as a tree diagram (area, device, measured value).

e With the Chart Explorer data rows can be added or deleted by double-clicking on the
appropriate measurement value.

e Data rows can also be added/deleted through the context menu.

ChartExplorer
Devices

= %) areal
{#) ds500 192. 168.0.241:502 ModbusID:
{#) 230 192.168.0,230:502 ModbusID: 1
{#) 234 192,168,0,234:502 ModbusID: 1
-9 242 192.168.0.242:502 ModbusID: 1
{p) A1-1: Ala [*Ctd]

() A1-2: Alb [%erH]

-(p) A1-3: Adc [%]

LB Remove Series
- $) area2

Line Style Settings
¥-Axis Settings

Configure Alarm

€ 1 3

Scrolling Options
¥-axis Scrolling ¥-axis Zooming
[ ¥-axis Scroling [ ¥-axis Zooming

Day |Calendar Week | Manith I Custom I o [

Day: 4716720131200 AM -~

Default Apply

lllustration 11: Diagram Explorer
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e The line style can be changed via the context menu:

G~ Chart Properties ==

Settings Advanced Settings
Color. _ Show Alam Borders
Style D /| Show Average

N Show Mexdmum
Marker Show Minimum
Thickness 2 L

—

lllustration 12: Line Style

¢ In addition, the setting of the Y-axis is changed via the context menu. An Y-axis is added for
each measured variable.

G~ Axis Settings @

Puiz-Y Settings
V| Auto Scale

Mz 25.01

Mir: 2261

[ ok [ cancel |

lllustration 13: Y-axis scaling

e The alarm configuration can also be started from the context menu (see 8 Alarm
Configuration).

e Depending on the selection of the TabControl in the Diagram Explorer, a different data field is
loaded. The data is read optimized from the database (grouping of data - the maximum
number of possible data points (screen width)). With the button "<<" or ">>" the same time
span before or after is read from the database.

e Using “Default” the range is set to the maximum range.

¢ The Diagram Explorer can be docked to the left or right, or used as a floating window
(Windows standard).
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5.1 Diagram View

¢ Inthe diagram view, the selected area is presented graphically:
& CS Instruments GmbH - OMLINE Monitoring Client ==
File  Edit Miew Extraz  Info ChartExplorer o
Chart view ‘ Statistic I Tabular view I Tabular view raw data | Devices
B4 areal
' = S 25 4 T - #) ds500 192.168.0.241:502 Modbus|D: 1
4300 4 £ F o434 ¥ o () 230 192.168.0.230:502 ModbusID: 1
1.1 4 -(#) 234 152.168.0.234:502 ModbusID: 1
2481 oo -(4) 242 192.168.0.242.502 ModbusID: 1
4200 42 o R () AT-1: Ala [Cid]
187 a6 {Q)) A1-2 Al [%H]
o] 956 | RO]A1-3 Ale ]
4100 10,5 o 41 Q) B1-1: - [l¥min]
2.4 a3 ] Q) B4-8 -]
4000 102 40 - Y area2
ge | 221 2
3900 -| ' 39
9.6 - 24 =
3800 38 - a4
93 23.5 -
3700+ 37 A 8.1
s ]
23.6 4
3600 - —_— 36 78
23.4
7.5
3500 - g4 35 Seroling Options
23.2 .2 ¥eaxs Scrolling K-axis Zooming
3400 817 34 [7] Y-zds Serolling [T ¥-axis Zooming
23 6.9 4
8 Day | Calendar Week | Month | Custom [ Real Time Data
3300 + 33
.5 ] 228 6.6 Day 4/16/2013 12.00 AM -
3200 | 32 6.3 : : :
™ O™ o e
B o e
Al-1: Ala B AT-2: Al B A1-3: Alc B BI-1: - [ Ba-B: - [W] Hoply
s Connected 4490 - Value doesn't match *Ctd!
lllustration 14: Diagram View
e Zoom
Depending on the selection in the Diagram Explorer the X-axis (X-axis zoom) and/or Y-axis
(Y-axis zoom) can be enlarged or reduced by using the scroll wheel. The selection can also be
made via the context menu.
By pressing the Shift key and selecting the desired range, the selected area is enlarged.
By pressing the shift key and clicking an enlargement by one increment will be made.
Pressing the ALT key and clicking will effect a reduction.
Pressing the STRG key and +-key will lead to an enlargement by one increment.
Pressing the STRG key and — key will lead to a reduction by one increment.
e Measuring points:
If the data does not have to be grouped for displaying, the raw data will be shown. The
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measured value will be output in the tooltip.

7 CS Instruments GrsH - ONLINE Monitoring Client

Defaut Focty

s T v T

lllustration 15: Raw data diagram

e Scrolling:
Depending on the selection in the Diagram Explorer a scrolling is carried out along the x-axis
(X-axis scrolling) and/or the Y-axis. The selection can also be made via the context menu.
Hold down the left mouse button for scrolling.

e Reset Y-scaling:
Using the context menu "Zoom -> Reset Y-Axis scaling” all Y-axes are reset to auto scaling.

e Data reloading:
After zooming, you can use the context menu "Accept current time range" to load the
maximum amount of data for the selected area.

e Moving average:
Using the context menu or the menu "Edit -> Moving average -> Display” the moving average
can be displayed/suppressed.
The moving average can be configured via the menu "Edit -> Preferences -> Moving

averag e".
& Moving Average Configuration @

Settings
Indicator Type: ISimpIe Moving Average "
Points cournt: 100 =
Kind: IEnveIope only "
Envelope (%): |5 =

[ ok ][ Cancel |

lllustration 16: Moving average

e Export:
The current diagram can be printed or exported as various types of documents (PDF, HTML,
MHT, Rich Text, Excel, CSV, Text, graphically) via the context menu "Export ..." or the menu
"File -> Export ...".

The chart diagram can be exported in the following formats:
a) Hourly: One chart diagram per hour.
b) Daily: One chart diagram per day.
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c) Weekly: One chart diagram per week.
Selected timespan: print of current chart diagram.

¢ Real-time data:

The current data can be recorded by activating the tab "real-time data" in the Diagram

Explorer. The maximum time frame to be displayed is specified in seconds.

e Saving:

The current settings (line style, time range ...) can he saved via the menu "File -> Save" and
reloaded at a later point in time. Please note that the data is not stored in the file, but loaded
from the database when the file is opened. When the diagram data is saved the file extension

™. csch" is used.

5.2 Statistics

e The loaded data will be analyzed statistically, and can be displayed through the tab

"Statistics".

7 CS Insruments GeioH - ONLINE Montoring Client
fle it Yiew Gt Info
Crot vew | S0t | Tatndes vim | Tabude e rom dte

Statistic Report

User: tebner
Timespan: 4/16/2013 10:10 AM - 4/16/2013 10:11 AM
areal
242 Device-ID: 6 Modbus-ID: 1 IP-Address: 192.168.0.242
1n Value name Unit Average Min Time of min Max Time of max Sumalarm 1 Sum alarm 2
56 |A1-1: Ata ectd 9.756 9.723 4/16/2013 10:10:34 AM| 9.793 14/16/2013 10:10:47 AM 0 0
57 [Ar2:a1b %rH 41.676 41.605 4/16/2013 10:11:22 AM| 41.765 4/16/2013 10:10:47 AM 0 0
58 [A13: Atc °C 23.477 23.455 4/16/2013 10:10:45 AM| 23.495 1/16/2013 10:11:52 AM 0
59 [B1-1; - Vmin 10.756 10.723 14/16/2013 10:10:34 AM| 10.793 (4/16/2013 10:10:47 AM 0 0
60 [B4-8: - - 4167.972 4160.51 4/16/2013 10:11:22 AM| 417648 [4/16/2013 10:10:47 AM 0 0
< Connected
e — e

lllustration 17: Statistical analysis

Defaut Focty

4492 - Volue doesn't match *Ctd!
-

e With the context menu or the menu "File -> Export ..." the statistical analysis can be output

with or without graphics.
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5.3 Tabular View

e The loaded data will be output in a tabular form and can be displayed through the tab "Tabular
view".
& CS Instruments GmbH - OMLINE Monitoring Client =N =
File Edit View Extras Info ChartExplore L3
Chart view | Statistic | Tabular view | Tabular view mw data Devices ]
. et et yesl  |aeal  aeal 7 33‘155011 192.168,0.241:502 Modbus D:
Al-1: Ala | Al-2:Alb |Al1-3:Alc  Bl-1: — |B48:— 230 1592.168.0.230:502 ModbuslID: 1
[*Ctd] [2%r H] =] Dmin] [ 234 192.168.0.234:502 ModbusiD: 1
¥ /152013 10:10:35 AM 372 165 10720 416502 242192.168,0.242:502 ModbusID: 1
— (F) A11: Ata [Cud]
4/16/2013 10:10:36 AM 41.65 10.723| 41565.29 Q) A1-2 Alb [%H]
4/16/2013 10:10:37 AM 41.66 10.728| 4165.65 () A1-3: Ale [C]
4/16/2013 10:10:33 AM 41.67 10.730| 4166.54 () B1-1: - [/min]
4/16/2013 10:10:39 AM 4168 10.736| 4167.80 ©@ area{zg) Big -1
4/16/2013 10:10:40 AM 4170 10.740| 4169.09
4/16/2013 10:10:41 AM 41.72 10,745 4170.77
4/16/2013 10:10:42 AM 4173 10.753( 417277
4/16(2013 10:10:43 AM 41.74 10.758| 4174.9%
4/16/2013 10:10:44 AM 4175 10.763| 4176.00
4/16/2013 10:10:45 AM 41,75 10.769| 4175.21
4/16/2013 10:10:46 AM 4176 10,777 4176.31
4/16/2013 10:10:47 AM 4176 10.787| 4176.41
4/16/2013 10:10:48 AM 4175 10.790( 4176.11
4/16/2013 10:10:49 AM 41.75 10.790| 4175.66
4/16/2013 10:10:50 AM 41.74 10.783 4174.51
4{16/2013 10:10:51 AM 4173 10.780| 4172.90 Scroling Options
4/16/2013 10:10:52 AM 41.71] 10.773| 4171.74 s ST e BrrrE
4/16/2013 10:10:53 AM 4171 10.770| 4170.93 [ Yais Scroling [ Y-mis Zooming
4/16/2013 10:10:54 AM 4170 10,770 4170.32
4/16/2013 10:10:55 AM 4170 10,770 4170.07 Day | Calendar Week | Month | Custom | Real Time Data
HUEAIED WEIERE LT ETE (E770| <ERE From: 4/16/2013 10:10:34 AW -
4/16/2013 10:10:57 AM 4170 10.770| 4169.80 To: 4/16/2013 101159 AM -
4/16/2013 10:10:58 AM 41.69 10.770| 4169.67
4/16/2013 10:10:59 AM 41.69 10,770 4159.54
4/16/2013 10:11:00 AM 41.69 10.770| 4159.20
4/16/2013 10:11:01 AM 41.69 10.763| 41563.69
4/16/2013 10:11:02 AM 41.68 10.760| 4168.23 Apply
s Connected 4492 - Value doesn't match *Ctd! .2
lllustration 18: Tabular View
o If an area within a table is marked, you can use the context menu "Accept current time frame"
to reload the current data range.
e The tabular view can be output through the context menu "Export ..." or via "File -> Export ...".
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5.4 Raw Data

¢ Inthe tab "raw data" the raw data of the database is output for the selected measurement
values. If the number of data > width of the chart the grouped data will be output, otherwise
the raw data.

@ CS Instrurnents GmbH - ONLINE Monitoring Client
File Edit View Extras Info tExplore! o
Chart view I Statistic I Tabular view | Tabular view raw data : Eences
B4 areal

Time: AreaMame  Device Mame [P Address ModbusID  Value Name  Value Max Value 1= () cs500 152168 0 241502 ModbusID: 1
4/16/2013 10:11:19 AM |areal 242 192.168.0.242 1|A1-2: Alh 416400  4L6414 {#) 230 192.168.0.230:502 MadbusID: 1
4/16/2013 10:11:20 AM |area 242 182,168.0.242 1Atz ath AL.6314] 416394 () 234152.168.0.234:502 ModbusiD- 1

-4 242 152.168.0.242:502 ModbuslD: 1
4{16/2013 10:11:21 AM |areal 242 192.168.0.242 1|a1-2: Alh 41.6178| 416195 {3) AT-1 Ala [C
4{16/2013 10:11:22 AM |areal 242 192,168.0.242 1|A1-2: Alb 41,6098|  4L.6109 {p) A1-2: Alb [trH]
4/16/2013 10:11:23 AM | area 242 192, 168.0,242 1[a12 atb 41,6060|  41.6098 {p) A13: Ale [C]
4/16/2013 10:11:24 AM |areal 242 192,168.0.242 1|A1-2 Alb 416105  4L6137 8)) gl; :{I_]/m‘n]
4{16/2013 10:11:25 AM |areal 242 192.168.0.242 1|a1-2: Alb 41.6148| 416195 area?
4{16/2013 10:11:26 AM |areal 242 192,168.0.242 1|A1-2: Ah 41.6204| 416238
4{16/2013 10:11:27 AM |areal 242 192,168.0.242 1|A1-2: Atb 41.6252| 416305
4{16/2013 10:11:28 AM |area1 242 192.168.0.242 1|a1-2: alb 41.6327| 416414
4{16/2013 10:11:29 AM |areal 242 192,168.0.242 1|A1-2: Alb 41,6433| 416539
4{16/2013 10:11:30 AM |areal 242 192,168.0.242 1|A1-2 Ath 41.6562| 416652
4/16/2013 10:11:31 AM |areal 242 192,168.0.242 1|A1-2: Atb 41,6681 416797
4{16/2013 10:11:33 AM |areal 242 192.168.0.242 1|A1-2: Alb 41.6842| 416965
4{16/2013 10:11:34 AM |areal 242 192,168.0.242 1|A1-2: Ath 41.6080| 417043
4{16/2013 10:11:35 AM |areal 242 192,168.0.242 1|A1-2 Ath 41,7058  4L.7125
4{16/2013 10:11:36 AM |areal 242 192.168.0.242 1|a1-2: Ath 41,7143 417242
4{16/2013 10:11:37 AM |areal 242 192.168.0.242 1|A1-2: Alb 41.7252| 417289
416/2013 10:11:39 AM |areal 242 192.168.0,242 1|A1-2: Alh 41,7280 41,7289 Scroling Options
4/16/2013 10:11:40 AM |areal 242 192,168.0.242 1|A1-2: Atb 41,7171 41,7203 Xeanis Scrolling X-ads Zooming
4{16/2013 10:11:41 AM |areal 242 192.168.0.242 1|a1-2: Alh 41.6998|  41.7043 [T Y-ais Serolling [C] -zds Zooming
4{16/2013 10:11:42 AM |areal 242 192,168.0.242 1|A1-2: Alh 41,6802|  4L6816
4/16/2013 10:11:44 AM | areal 242 192.168.0.242 1|at2 ath 416712 416746 Day | Calendar Week | Month | Custom | Real Time Data
4/16/2013 10:11:45 AM |areal 242 192,168.0.242 1|A1-2 Alb 416634  4L6641 From: 4/16/2013 10:10:34 AM -
4{16/2013 10:11:46 AM |areal 242 192.168.0.242 1|A1-2: Alh 41.6592|  41.6605 To: 4/16/2013 10:11:59 AM -
4{16/2013 10:11:47 AM |areal 242 192,168.0.242 1|A1-2: Ah 41.6534| 416533
4{16/2013 10:11:48 AM |areal 242 192,168.0.242 1|A1-2: Atb 41,6517| 416533
4{16/2013 10:11:49 AM |areal 242 192.168.0.242 1|a1-2: Alb 41.6552|  41.6605
4{16/2013 10:11:50 AM |areal 242 192,168.0.242 1|A1-2: Alb 41,6608  4L.6621| _

1 5 Default Apply
sz Connected 4492 - Value doesn't match “Ctd! .2

lllustration 19: Raw Data

e The raw data can be output through the context menu "Export ..." or via "File -> Export ...".

e With the context menu of the table heading the raw data can be output:

a) sorted:

& CSInstruments GmbH - ONLINE Monitoring Client =n =R

File Edit View Extras [Info Q

o

| Chart view | Statistic | Tabular view |} Tabular view raw dat B

=

Time 4+ AreaMame Device Name  IP Address Modbus ID Value Name  Value Max Value  MinValue  Unit isAlarml  is Alarm2 - ﬁ

s 00 et 22 m2168022 1AVEABR | 97 97M STd 1 0
416/2013 10:10:34 AM |areal 242 192.168.0.242 1(A1-2: Alb 41.6486 41.6539 41.6473 | YorH a a
416/2013 10:10:34 AM |areal 242 192.168.0.242 1|B1-1: — 10,7229 10.7241 10,7227 ||fmin a a
416/2013 10:10:34 AM |areal 242 192.168.0.242 1|B4-8: — 4164.8599| 4165.3900( 4164.7300|- a a
4f16/2013 10:10:35 AM |areal 242 192.168.0.242 1|B1-1= — 10.7243 10.7252 10,7241 ||/min a a
416/2013 10:10:36 AM |areal 242 192.168.0.242 1(A1-2: Alb 41.6541 41.6559 41,6539 | %erH a a

4/16/2013 10:10:36 AM |areal 242 192.168.0.242 1|B4-8: — 4165.4102| 4165.5900| 4165.3900]- 1] ol -
z3 Connected 4492 - Value doesn't match “Ctd! .:

lllustration 20: Chronological sorting ascending
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b) filtered:
& CSInstruments GmbH - ONLINE Monitoring Client =n =R
File Edit View Extras [nfo Q
| Chart view | Statistic | Tabular view | Tabular view mw data Eﬁ
Time 4+ AreaMame Device Name  IP Address Modbus ID Value Name ™ Value Max Value  MinValue  Unit isAlarml  is Alarm2 - %
b 4/16/2013 10:10:34 AM |areal 2492 192.168.0.242 1:A1-2: Alh 41.6486 41.6539 41.6473 | %erH a a
416/2013 10:10:36 AM |areal 242 192.168.0.242 1(A1-2: Alb 41.6541 41.6559 41.6539 | %erH a a
4/16/2013 10:10:37 AM | areal 242 192.168.0.242 1(A1-2: Alb 41.6583 41.6680 41.6559 | %rH 1] 1]
416/2013 10:10:38 AM |areal 242 192.168.0.242 1(A1-2: Alb 41.6707 41.6816 41.6680 | YorH a a
4/16/2013 10:10:39 AM |areal 2492 192.168.0.242 1(Aa1-2: Alb 41.6862 41,7043 41,6815 | %erH a a
4/16/2013 10:10:40 AM |areal 242 192.168.0.242 1(A1-2: Alb 41.7075 41,7203 41,7043 | %orH a a
4MAIINTT AN+ 1041 &M | areat 247 197 168 N 747 1la1-7- a1k a1 7774 a1 735a] 41 70zl orH n n
x Edit Filter
z3 Connected 4493 - Value doesn't match *Ctd!
lllustration 21: Filters - Value Name Al1-2: Alb
c) grouped:
& CSInstruments GmbH - ONLINE Monitoring Client =n =R
File Edit View  Extras Q
| Chart view | Statistic | Tabular view | Tabular view mw data Eﬁ
Time 4+ AreaMame Device Name  IP Address Modbus ID  Value Max Value  MinValue Unit isAlarml  is Alarm2 - %
+ Value Name: Al1-1: Ala
+ Value Name: A1-2: Alb
+ Value Name: A1-3: Alc
+ Value Name: B1-1: --
b i+ Value Name: B4-8: —
4f16/2013 12:00... |areal 2492 192.168.0.242 1| 3356.2483| 3357.0700| 3354.7300(- a a
4f16/2013 12:00... |areal 242 192.168.0.242 1|3363.8148| 3372.0300( 3356.0900(- a a
416/2013 12:01... |areal 2492 192.168.0.242 1| 3367.8250| 3371.7200| 3361.1300(- a a
4/16/2013 12:02... |areal 292 192.168.0.242 1(3360.3261| 3365.3100( 3356.6800|- 1] 1]
416/2013 12:02... |areal 2492 192.168.0.242 1| 3367.2170| 3368.0100| 3365.3100(- a a
AL IINADZ 4702 Eryee AT 407 4£0 N 1AT il 2222 coTn 22LT _Annn 22LC COAN n n T

z3 Connected

4494 - Value doesn't match *Ctd!

lllustration 22: Grouping Name Value

6 Alarm

¢ Viathe menu item "View -> Alarm", the alarm window is opened.

e Inthe tab "Current Alarms" the current alarms are displayed.

o Each alarm must be acknowledged. The acknowledgment is performed by clicking on the
desired alarm and a subsequent acknowledging via the context menu.

e Alarms that are no longer active and have been acknowledged will be moved to the alarm
history. The alarm history can be opened from the tab "Alarm History".

e Inthe alarm history the last 2000 entries are stored.

e The server errors can be viewed from any OMClient via the tab "Server Messages". Here, the
last 2000 entries are stored, which occurred on the server side (OMServer).
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e Via the menu item "File -> Export .

'arschau

" the current view can be exported.

Datei Ansicht Hintergrund ~

NREE &alyll O -] mBE-=E- Q-

Alarm Historie

Zeit Quitt Geratename Modbus Name Messwert Alarmtext
ein | Mttt [ et | pecke | 0n:07:s2 Halle 1 DS300 Nr. 2 Halle 1 2 Durchfluss Alarmz: Durchfluss >12(de)
160N | IO [ 04N | pjsecke | n0:07:54 Halle 1 DS300 Nr. 2 Halle 1 2 Durchfluss Alarmi: Durchfluss >=8 (de)
16042001 | 16042000 [ 10042000 | pjaecke | 00:07:11 Halle 1 DS300 Nr. 2 Halle 1 2 Durchfluss Alarmz: Durchfluss >12(de)
16040 | IO [ 040 | pjeeckle | 00:07:15 Halle 1 DS300 Nr. 2 Halle 1 2 Durchfluss Alarmi: Durchfluss >=8 (de)
1590;72%1 11690;72311 13902422171 pjaeckle 00:07:10 Halle 1 DS300 Nr. 2Halle 1 2 Strémung Alarmi: Strémung > 4 (de)!
1604000 | IO [ T4 | pjaecke | 00:07:03 Halle 1 DS300 Nr. 2 Halle 1 2 Stromung Alarm2: Stromung > 6 (de)
Seite Lvonl 1% =) {} @

lllustration 23: Export
e The preview can be printed or exported as various types of documents (PDF, HTML, MHT,
Rich Text, Excel, CSV, Text, graphically) via the menu "Export ...".

o With the context menu of the table heading the tabular view can be:
a) sorted

G Alarme - - —__ @M‘

Datei
Alduelle Alame | Alam Historie | Seryver Meldungen|

Time Set Time Reset Time Quit User Name Duration «  Area Name Device Name Modbus ID Value Mame  Alarm Text
16.04,2011 - 18:57:39 | 16.04.2011 - 18:57:40 | 16.04.2011 - 19:04:42 | pjaeckle 00:07:03  |Halle 1 D5300 Mr. 2 Halle 1 2|strémung Alarm2: Strémung = 6 (de)
16.04.2011 - 18:57:37 | 16.04.2011 - 18:57:41 | 16.04.2011 - 19:04:47 | pjaeckle 00:07:10  |Halle 1 DS300 Mr. 2Halle 1 2|Strémung Alarm1: Strémung > 4 (de)!
16.04.2011 - 18:57:34 | 16.04.2011 - 18:57:53 | 16.04.2011 - 19:04:45 |pjaecke 00:07:11  |Halle 1 DS300 Mr, 2 Halle 1 2 |Durchfluss Alarm2: Durchfluss =12(de)
16.04.2011 - 18:57:34 16.04.2011 - 19:04:4% |pjaeckle 00:07:15  |Halle 1 D5300 Mr. 2 Halle 1 2 |Durchfluss Alarm1: Durchfluss ==8 (de)
Halle 1
. 2Halle 1 2|Durchfiuss Alarm1: Durchfluss ==8 (de)

lllustration 24: "Duration” sorting, ascending

filtered

| & Alarms
File
Actual Alarms |Narrn History | Server Messages
Time Reset | Time Quit User Mame Modbus 1ID Value Name Alarm Text o
- Time Set: 4/18/2013
»
1|ctd 1-Error
-~ Device Name: 242
1(A1-1: Ala 1-Error
1(A1-3: Alc 1-Error
4f18/2013 - 10:51:55 AM 1|A1-1: Ala 1-Error
4/18/2013 - 10:52:27 AM 1/Al-1: Ala 1-Error
4f18/2013 - 10:53:13 AM 1|Al-1: Ala 1-Error
x EditFilter .

lllustration 25: Filters - Timeset from April 18, 2011

10/2/2014 Client Manual Rev. E Page 22 of 28



CS Soft Network Client

¢) grouped
< Nare - - | EE—)
Datei

Aktuelle Alame | Aam Historie I Server Meldungen

Area Name =« N
Device Name  +
Value Name

Time Set
~ AreaName: Halle 1

Time Reset

-

Time Quit

User Name

Modbus ID

Alarm Text

+ Device Name: DS300 Nr. 1 Halle 1

- Device Name: DS300 Nr. 3 Halle 53

~ Value Name: Rel. Feuchte K 2-1

[18.042011- 18:32:25 |

3| Alarm1: Rel. Feuchte K 2-1 >=50 (de)

+ Value Name: Temperatur K 1-1

+ Value Name: Temperatur K 2-1

[18.04.2011 - 19:10:29

[19.04.2011 - 09:32:45 |

3| Alarm1: Temperatur K2-1 <=15.0 *C (de)

lllustration 26: Grouping AreaName, DeviceName, ValueName

Thus, enabling a detailed analysis of the alarms.

7 Analysis

The menu item "View -> analysis" initiates the consumption analysis.

@ Analysis
File  Extras
DEH
Configure analysis

possible devices

[=R areal
=-ds500
&R

i B2-1: BZa [m¥/h]
e B2-2: B2 ]

i B4-1: Bda [mi/h]
.. B4-2: Bdb ]

Timespan

Calendar Week | Morth | Year | Custom|

devices for report

Calculztion

Marth: April -
2013 =

Year:

cumency EUR

[T report type shift

Generate
Report

lllustration 27: Consumption Analysis
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The left pane lists all devices with consumption sensors, which are not considered in the

consumption analysis.

The right pane lists all devices with consumption sensors, which are considered in the

consumption analysis.

With a double-click complete fields or only individual devices or channels can be moved from

left to right or right to left.

The selected area/unit/measuring channel can also be marked and moved with the "left arrow"

or "right arrow" buttons.

The order of the areas, devices and measurement channels can also be defined. For this, use

the "up arrow" and "down arrow" buttons.

Please note, that in order to execute a correct overall calculation devices that are included in a

main or subtotal may not be considered.

The configuration can be saved through the menu "File -> Save" or via the appropriate icon. A
saved configuration can be loaded at a later point in time can via "File -> Open". The file
extension "*, csua" is used for the configuration files of the consumption analysis. The menu
"File -> New" enables the creation of a new configuration.

Through the menu item "Extras->Config->Price" a price per unit as well as the rate
selection/rate definition can be defined for every consumption channel.

@ Configuration Price per unit

= [ B [l |

Value | Unit

Channel name

Area Device Channel

[ BEE"E DE-1234 (DS500) A2
DE-1234 | DE-1234 (D5500) [B1

AZb
Gesamt |kWh

Kompressor m?

Kunstoff

Dual tariff

Tariff 1 Tariff 2
Price per unit  Price per unit
[eur] [eur]

Tariff 15tart  Tariff 1End  Tariff 2 Start

1.0000

DE-1234 | DE-1234 (DS500) |B2 Kunstoff 2 gesamt |kg

1.0000

Tariff 2 End

lllustration 1: Consumption Analysis configuration

Up to 5 shifts can be defined via the menu point ,Extras->Config->shift work”. The shifts have
to be carried out within one day and are not allowed to overlap, otherwise there will be an
error message when confirming the input with the ,,OK* button.

The starting point of the first shift is allocated to the current day or the following day via the list

field ,Allocation of the shift start 1 to“.

Example:

Example 1 Example 2

Start of shift: 22:00 h Start of shift: 22:00 h
End of shift: 6:00 h End of shift: 6:00 h
Allocation: next day Allocation: actual day

If the first shift e. g. starts on Sunday at
22:00 h and ends on Monday at 6:00 h the
shift in this example will be allocated to
Monday.

If the first shift e. g. starts on Sunday at
22:00 h and ends on Monday at 6:00 h the
shift in this example will be allocated to
Sunday.
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~
@ Configuration shift work E@g
court of shifts 3 $
Nurnber Name Start End
b 00:00:00 00:00:00
2|shift 2 000000 00:00:00
3|shift 3 000000 00:00:00
Mapping start of shift 1to [adual day ']
[ ok ][ cancel |

lllustration 2: Configuration shift work

e Please observe - that devices which are located in a main or sum branch may not be
included if a correct sum-calculation is to be performed.
Additionally, in order to perform a correct sum calculation only consumption variables
with the same unit may be included.

o Depending on the selection of the TabControl a weekly, monthly or annual report is create.

L9 Preview =5 (E=R 5
File View Background -
BN EE FeHE ORI aw ] PR P BI@-E @ -

Consumption Analysis of Month 4/2013
calendar wesk
‘Channel Uinit Description 14 i5 16 17 18 Total
areal
ds500
A2 startcount ZS0STED IET4E0
m & oo ISE4SED 56370
m® total 751382 7E7300 1835782
anerage S18l6 42419 30021
minwalue 47302 41285
maEra e 4850 SST0E S7IET
R f== 3 75138280 TETEOO.00 257000.00 1835783.00 -
Pagel of 3 61% (=) 1 f C

lllustration 28: Consumption Analysis

e The preview can be printed or exported as various types of documents (PDF, HTML, MHT,
Rich Text, Excel, CSV, Text, graphically) via the menu "Export ...".
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8 Alarm Configuration

e The alarm configuration can be called up in the "Overview" view via the device context menu
"Alarm configuration”. _
@ CSInstruments GmbH - ONLINE Monitoring Client [odl-E ==
File Edit View Extras Info

D5 HE; b @@

description

temp

"""" ima YorH
graphical 10 min

m

graphical 20 min

graphical 30 min

graphical 1h

graphical 2h

graphical 5h

graphical 10h

graphical 24h

graphical 1 week

graphical 1 month

Configure alarm

< m »

s Connected 4497 - Value doesn't match “*Ctd! .:

lllustration 29: Device context menu alarm configuration

¢ In addition, the alarm configuration can be executed from the context menu of the Diagram

Explorer:
@ CSInstruments GmbH - ONLINE Monitoring Client =N NoR ==
File Edit View BEdras Info ChartExplorer r
Chart view |Slat|st|c | Tabular view | Tabular view raw data e
=-(8) areal

31-{#) ds500 192.168.0.241:502 Modbus|D: 1
+ -{#) 230 192.168.0.230:502 MadbusID: 1
41-{#) 234 192.168.0.234:502 ModbusID: 1
= ) 242 152.168.0.242:502 ModbusID: 1
£ A1 ATz [Cid]
~{9 A1-2: A [rH]

8 i1 Add Series
y ? B4s Configure Alarm
H-(§) area

Trromiioe
Xads Scroling X-ands Zooming
[7] Y-zds Scroling [[] Y-axis Zooming

Day  |Calendar Week | Month | Custom | Real Time Data

Day: 4/16/2013 12:00 AM -
<< ¥

sy Connected 4499 - Value doesn't match *Ctd!

lllustration 30: Diagram Explorer Alarm Configuration
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e 2 limit values can be set for each measured value. Depending on the definition the following
variants are possible:

A) pre-alarm + main-alarm
B) lower limit + upper limit

For each alarm a switch-on delay and/or switch-off delay can be defined. An alarm text can be
selected in the combo box "Alarm text". The definition of alarm texts is conducted either in the
OMServerGUI or the OMClient (see 3.3.1 Alarm texts).

G AlarmConfiguration - A1-3: Alc @
Aam 1 Alam 2
Alam type: 3 Alam type:
Threshald: 0.00000 : Threshold: 0.00000
Switch on delay (ms): |0 : Switch on delay {ms): |0
Switch off delay (ms): |0 : Switch off delay {ms): |0
Alam tesd: Alam text:
1 - Emor 1- Emor
@
lllustration 31: Alarm configuration, pre-alarm - main-alarm
¢~ AlarmConfiguration - A1-3: Alc @
Mam 1 Mam 2
| Enable alarm Enable alam
Alam type: > - AMarm type: > -
Thresheld: 0.00000 = Threshald: 0.00000 =

Switch on delay {ms): |0 Switch on delay (ms): |0

Ay
Alr

Switch off delay (ms). |0

4|+

Switch off delay ms): |0
Alam text: Alarm texd:

B3

1-Eror -] [1-Emwr

Unlock [ ok ][ cancal |

lllustration 32: Alarm configuration, lower/upper limit
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9 Support and Service

If you have questions about our products or require technical support for the installation or use of our
software, please contact us by e-mail:

info@cs-instruments.com

or by phone call:
+49 461 7002025

Phone support and Teamviewer access
(15 minutes = 30 Euro, minimum 45min)

We will answer all inquiries within 24-48 hours.
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